<!doctype html>
<html lang="en">
<head>
  
    <meta charset="UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <title>Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium | The National Academies Press</title>
    
                <meta name="DC.creator" content="National Academy of Engineering">
                <meta name="DC.identifier" content="doi:10.17226/23659">
                <meta name="DC.issued" content="2017-01-31">
                <meta name="DC.title" content="Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium">
                <meta name="article:publisher" content="https://www.facebook.com/NationalAcademiesPress">
                <meta name="citation_author" content="National Academy of Engineering">
                <meta name="citation_doi" content="10.17226/23659">
                <meta name="citation_isbn" content="978-0-309-45036-2">
                <meta name="citation_pdf_url" content="https://www.nap.edu/download/23659">
                <meta name="citation_publication_date" content="2017/01/31">
                <meta name="citation_title" content="Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium">
                <meta name="description" content="Download a PDF of &quot;Frontiers of Engineering&quot; by the National Academy of Engineering for free. Description: This volume presents papers on the topics covered at the National Academy of Engineering&#039;s 2016 US Frontiers of Engineering Symposium. Every year the symposium brings together 100 outstanding young leaders in engineering to share their cutting-edge research and innovations in selected areas. The 2016 symposium was held September 19-21 at the Arnold and Mabel Beckman Center in Irvine, California. The intent of this book is to convey the excitement of this unique meeting and to highlight innovative developments in engineering research and technical work.">
                <meta name="og:description" content="This volume presents papers on the topics covered at the National Academy of Engineering&#039;s 2016 US Frontiers of Engineering Symposium. Every year the symposium brings together 100 outstanding young leaders in engineering to share their cutting-edge research and innovations in selected areas. The 2016 symposium was held September 19-21 at the Arnold and Mabel Beckman Center in Irvine, California. The intent of this book is to convey the excitement of this unique meeting and to highlight innovative developments in engineering research and technical work.">
                <meta name="og:image" content="https://www.nap.edu/cover/23659/450">
                <meta name="og:site_name" content="The National Academies Press">
                <meta name="og:title" content="Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium">
                <meta name="og:type" content="book">
                <meta name="og:url" content="https://www.nap.edu/catalog/23659/frontiers-of-engineering-reports-on-leading-edge-engineering-from-the">
                <meta name="prism.doi" content="10.17226/23659">
                <meta name="twitter:card" content="summary">
                <meta name="twitter:description" content="This volume presents papers on the topics covered at the National Academy of Engineering&#039;s 2016 US Frontiers of Engineering Symposium. Every year the symposium brings together 100 outstanding young leaders in engineering to share their cutting-edge research and innovations in selected areas. The 2016 symposium was held September 19-21 at the Arnold and Mabel Beckman Center in Irvine, California. The intent of this book is to convey the excitement of this unique meeting and to highlight innovative developments in engineering research and technical work.">
                <meta name="twitter:image:height" content="675">
                <meta name="twitter:image:src" content="https://www.nap.edu/cover/23659/450">
                <meta name="twitter:image:width" content="450">
                <meta name="twitter:site" content="@theNASEM">
                <meta name="twitter:title" content="Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium">
                <meta name="twitter:url" content="https://www.nap.edu/catalog/23659/frontiers-of-engineering-reports-on-leading-edge-engineering-from-the">
              <link rel="canonical" href="https://www.nap.edu/catalog/23659/frontiers-of-engineering-reports-on-leading-edge-engineering-from-the">
        
      <script>
  if (document.location.hostname.search(/nap\.edu$/) < 0) {
    url = "http://www.na" + "p.edu" + document.location.pathname + document.location.search
    document.location.replace(url);
  }
</script>

<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script src="//cdn.optimizely.com/js/4128032166.js"></script>

<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="/includes/js/svg4everybody.ie8.min.js"></script>
<![endif]-->
<meta name="alexaVerifyID" content="02J2SepmgvpkhVXcfeE98cX3HKs" />

<link href="//www.nap.edu/stylesheets/topnav-lite.css" rel="stylesheet" type="text/css" />
<link href="//www.nap.edu/stylesheets/component.css" rel="stylesheet" type="text/css" />

<!--[if gte IE 5]> <style type="text/css"> #blanket {filter:alpha(opacity=65);}</style><![endif]-->

<!-- google analytics -->
<script src="//www.nap.edu/includes/nap_async_ga.min.js"></script>
<!-- google analytics -->

<!-- MC Goal Tracking -->
<script type="text/javascript">
  var $mcGoal = {'settings':{'uuid':'eaea39b6442dc4e0d08e6aa4a','dc':'us4'}};
  (function() {
     var sp = document.createElement('script'); sp.type = 'text/javascript'; sp.async = true; sp.defer = true;
    sp.src = ('https:' == document.location.protocol ? 'https://s3.amazonaws.com/downloads.mailchimp.com' : 'http://downloads.mailchimp.com') + '/js/goal.min.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sp, s);
  })(); 
</script>
        <link rel="stylesheet" href="/stylesheets/vendor/bootstrap-3.0.3/bootstrap.min.css">
  <link rel="stylesheet" href="/stylesheets/naphome.css" />
  <style>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</style>

  <link rel="stylesheet" href="/stylesheets/catalog.css">
       <style>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</style>

    <style>pre { background-color: transparent !important; }</style>

              
  </head>
<body>
  
                <a name="top" id="top"></a>
<header class="visible-print-block">
  <img src="/images/hdr_3dsunandnaptxt.png" alt="The National Academies Press">
</header>
<header id="topnav">
  
  <div id="header-large">
    <div class="topnav-inner">
      <ul class="site-links">
        <li class="menu"><a href="//www.nap.edu/content/about-the-national-academies-press">ABOUT</a></li>
        <li class="menu"><a href="//www.nap.edu/content/help-with-ordering">ORDERING</a></li>
        <li class="menu"><a href="//www.nap.edu/new">NEW RELEASES</a></li>
        <li class="menu"><a href="//www.nap.edu/content/help">HELP</a></li>
      </ul>
          
      <div class="row1">
                          <div id="browsemenu">
            <button id="bbt_Btn" class="dl-trigger" type="button">
              BROWSE TOPICS<span class="icon-menu bbt-toggle" data-icon="&#xe63b;"></span>
            </button>
            <div id="bbt-menu" class="bbt-wrapper">
              <ul class="dl-menu">
                              <li><a href="//www.nap.edu/topic/276" tabindex="0">Agriculture</a></li>
                              <li><a href="//www.nap.edu/topic/277" tabindex="0">Behavioral and Social Sciences</a></li>
                              <li><a href="//www.nap.edu/topic/292" tabindex="0">Biography and Autobiography</a></li>
                              <li><a href="//www.nap.edu/topic/278" tabindex="0">Biology and Life Sciences</a></li>
                              <li><a href="//www.nap.edu/topic/279" tabindex="0">Computers and Information Technology</a></li>
                              <li><a href="//www.nap.edu/topic/280" tabindex="0">Conflict and Security Issues</a></li>
                              <li><a href="//www.nap.edu/topic/281" tabindex="0">Earth Sciences</a></li>
                              <li><a href="//www.nap.edu/topic/282" tabindex="0">Education</a></li>
                              <li><a href="//www.nap.edu/topic/283" tabindex="0">Energy and Energy Conservation</a></li>
                              <li><a href="//www.nap.edu/topic/284" tabindex="0">Engineering and Technology</a></li>
                              <li><a href="//www.nap.edu/topic/285" tabindex="0">Environment and Environmental Studies</a></li>
                              <li><a href="//www.nap.edu/topic/287" tabindex="0">Food and Nutrition</a></li>
                              <li><a href="//www.nap.edu/topic/288" tabindex="0">Health and Medicine</a></li>
                              <li><a href="//www.nap.edu/topic/289" tabindex="0">Industry and Labor</a></li>
                              <li><a href="//www.nap.edu/topic/290" tabindex="0">Math, Chemistry, and Physics</a></li>
                              <li><a href="//www.nap.edu/topic/423" tabindex="0">Policy for Science and Technology</a></li>
                              <li><a href="//www.nap.edu/topic/293" tabindex="0">Space and Aeronautics</a></li>
                              <li><a href="//www.nap.edu/topic/294" tabindex="0">Transportation</a></li>
                              <li class="separator" style="border-top: 1px solid #cecece; margin: 5px 0;"></li>
                <li>
                  <img src="/images/icon_academyscope.png" alt="" class="academyscope-icon pull-right" style="margin: 6px 4px;">
                  <a href="/academy-scope">AcademyScope</a>
                </li>
              </ul>
            </div>
          </div>
                  
        <div class="phone">
          <span class="icon-menu" data-icon="&#xe603;"> </span> 800-624-6242
        </div>
          
        <ul class="user-links">
                  <li><a href="https://www.nap.edu/login.php?page=https%3A%2F%2Fwww.nap.edu%2Fcatalog%2F23659%2Ffrontiers-of-engineering-reports-on-leading-edge-engineering-from-the" class="userOff"><span class="icon-menu" data-icon="&#xe602;"> </span> Login</a></li>
          <li><a href="https://www.nap.edu/login.php?page=https%3A%2F%2Fwww.nap.edu%2Fcatalog%2F23659%2Ffrontiers-of-engineering-reports-on-leading-edge-engineering-from-the&action=new" class="register"><span class="icon-menu" data-icon="&#xe638;"> </span> Register</a></li>
                  <li>
            <a href="https://cart.nap.edu/cart/cart.php">
              <span class="icon-menu" data-icon="&#xe639;"> </span>
              Cart             </a>
          </li>
        </ul>
          
      </div>
      <div class="clearfix"></div>
      
      <div id="naplogo_bg_big" >
        <div class="nap-logo">
          <a href="//www.nap.edu">
            <img src="/images/hdr_3dsunandnaptxt.png" alt="The National Academies Press">
          </a>
        </div>
          
                          <div id="mobilesearch">
            <div class="searchwrapper depth">
              <form class="search-form" name="QueryForm" action="//www.nap.edu/search" method="get" title="Search NAP Books">
                <input class="search-term" required placeholder="Search 8,893 books by title, topic, ISBN, or DOI" type="Text" name="term">
                <input type="image" src="/images/hdr_searchicon.png" align="top" class="mobilesubmit">
              </form>
            </div>
          </div>
              </div>
    </div>
  </div>

  <div id="header-small">
    <div class="row mobile-inner">

      <div class="mobilenav">
        <div id="mobile_menuBtn">
          <span class="icon-menu nap-menu" data-icon="&#xe600;"></span> Menu
        </div>
      </div>

      <ul class="user-links">
                  <li><a href="https://www.nap.edu/login.php?page=https%3A%2F%2Fwww.nap.edu%2Fcatalog%2F23659%2Ffrontiers-of-engineering-reports-on-leading-edge-engineering-from-the" class="userOff"><span class="icon-menu" data-icon="&#xe602;"> </span> Login</a></li>
          <li><a href="https://www.nap.edu/login.php?page=https%3A%2F%2Fwww.nap.edu%2Fcatalog%2F23659%2Ffrontiers-of-engineering-reports-on-leading-edge-engineering-from-the&action=new" class="register"><span class="icon-menu" data-icon="&#xe638;"> </span> Register</a></li>
                  <li>
            <a href="https://cart.nap.edu/cart/cart.php">
              <span class="icon-menu" data-icon="&#xe639;"> </span>
              Cart             </a>
          </li>
      </ul>

      <div class="mobile-logo">
        <div class="logo-inner">
          <a href="//www.nap.edu"><img src="/images/hdr_3dsunandnaptxt.png" alt="The National Academies Press" align="middle"></a>
        </div>
				<div class="mobile-search">
				                   <form name="QueryForm" action="//www.nap.edu/search" class="search-form">
            <input type="text" name="term" class="search-term" required placeholder="Search by title, topic, ISBN, or DOI">
            <input type="image" class="mobilesubmit" src="/images/hdr_searchicon.png" align="top">
          </form>
        				</div>
      </div>

      <div class="mobilemenu">
       
        <ul class="site-links">
          <li class="menu"><a href="//www.nap.edu/content/about-the-national-academies-press"><span class="icon-menu" data-icon="&#xe635;"></span> About</a></li>
          <li class="menu"><a href="//www.nap.edu/content/help-with-ordering"><span class="icon-menu" data-icon="&#xe603;"></span> Ordering</a></li><li class="menu"><a href="//www.nap.edu/topic/"><span class="icon-menu" data-icon="&#xe66b;"></span> Topics</a></li>
          <li class="menu"><a href="//www.nap.edu/new"><span class="icon-menu" data-icon="&#xe637;"></span> New Releases</a></li>
          <li class="menu"><a href="//www.nap.edu/content/help"><span class="icon-menu" data-icon="&#xe63c;"></span> Help</a></li>
        </ul>
      </div>

    </div>
  </div>

  <div class="clearfix"></div>

</header>    
      <div itemscope itemtype="http://schema.org/Book">
    <link itemprop="additionalType" href="http://schema.org/Product"/>

          <link itemprop="bookFormat" href="http://schema.org/Paperback">
    
    <div class="heading-rows">
      <div class="container">
        <div id="titleblock-small">
                      <a class="catalog-title" href="https://www.nap.edu/read/23659">
              <span itemprop="name">Frontiers of Engineering:   Reports on Leading-Edge Engineering from the 2016 Symposium </span>
            </a>
                          <span class="bookyear">(<span itemprop="copyrightYear">2017</span>)</span>
            			 <div id="statusblock">
				 			                 <span class="glyphicon glyphicon-book"> </span>  <a href="#" title="Learn more about publication types" data-toggle="modal" data-target="#type-modal" class="report-type">Proceedings</a>   
                				
				
				
				
				
				
				</div>
                  </div>
        <br>
                  <div class="row">
          
                        <div id="cover" class="col-md-2 col-xs-3">
              <a href="https://www.nap.edu/cover/23659/450" class="cover-block" onclick="return GB_showImage('Cover Image', this.href)">
                <img class="img-responsive img-cover150" src="https://www.nap.edu/cover/23659/450" alt="Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium" itemprop="image">
                <div class="cover-zoom">
                 <span class="glyphicon glyphicon-zoom-in" > </span>
				 <span class="hidden-xs">View larger</span>
                </div>
				
				              </a>
            
            </div>
          
                        <div class="col-md-5 col-xs-7">
              <div id="titleblock">
                                  <a class="catalog-title" href="https://www.nap.edu/read/23659">Frontiers of Engineering: </a>
                  <span class="catalog-subtitle"><br> Reports on Leading-Edge Engineering from the 2016 Symposium</span>                  <span class="bookyear">(<span itemprop="copyrightYear">2017</span>)</span>          
                				
				<div id="statusblock">
				 			                 <span class="glyphicon glyphicon-book"> </span>  <a href="#" title="Learn more about publication types" data-toggle="modal" data-target="#type-modal" class="report-type">Proceedings</a>   
                				
				
				
				
				
				
				</div>
              </div>
            
            
                                          <div class="md-purchase-hdr">Purchase Options</div>
                <div id="purchase" class="panel panel-default">
                  <div class="panel-heading"><span class="lg-purchase-hdr">Purchase Options  </span>
                                          <span class="mynap_txt">MyNAP members save 10% online.</span>
                                              <a href="https://www.nap.edu/login.php?record_id=23659">Login</a> or <a href="https://www.nap.edu/login.php?page=https%3A%2F%2Fwww.nap.edu%2Fcatalog%2F23659%2Ffrontiers-of-engineering-reports-on-leading-edge-engineering-from-the&action=new">Register</a>
                                                            </div>
                  <div class="panel-body">
                                                                                                                    <a href="https://cart.nap.edu/cart/cart.php?list=fs&amp;action=buy%20it&amp;record_id=23659&amp;isbn=0-309-45036-5" class="btn btn-block btn-purchase" itemprop="offers" itemscope itemtype="http://schema.org/Offer">
                            <span class="icon-purchase" data-icon="&#xe639;"></span>
                                                          <link itemprop="availability" href="http://schema.org/InStock">
                                                        Buy Paperback:
                                                          <span itemprop="price">$45.00</span>
                                                        <meta itemprop="priceCurrency" content="USD">
                          </a>
                                                                                                      
                                  
                                             			   
                
                                				
				    
                        
                  </div>
                </div>
          
              
          
                        
             
            </div>
            
             
          
                         <div id="actions" class="col-md-3 col-xs-10">
              
              <div class="link-tools">
                <a class="email-this" href="javascript:void(0)" onClick="window.open('/catalog/sendthis.php?record_id=23659','friend','directories=no,titlebar=no,toolbar=no,location=no,status=no,menubar=no,scrollbars=no,resizable=no,width=500,height=395');">E-mail this page <span class="glyphicon glyphicon-send icon-link"> </span></a>
                                  <a class="embed-this" data-toggle="modal" href="#" data-target="#embed-modal">Embed book widget<span class="glyphicon glyphicon-heart icon-link"></span></a>
                              </div>   
          
              <div class="book-actions">
                                  <a href="https://www.nap.edu/login.php?record_id=23659&amp;page=https%3A%2F%2Fwww.nap.edu%2Fdownload%2F23659" class="btn btn-primary action-button action-download">Download Free PDF</a>
                                                  <a href="https://www.nap.edu/read/23659" class="btn btn-default action-button action-read">Read Online</a>
                                               </div>
            </div>
                        
               <!-- Modal for embed book widget -->
               <div class="modal fade fade" id="embed-modal" tabindex="-1" role="dialog" aria-labelledby="embedmodalLabel" aria-hidden="true">
                 <div class="modal-dialog" >
                   <div class="modal-content">
                     <div class="modal-header">
                       <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                       <h4>Embed Book Widget</h4>
                     </div>
                     <div class="modal-body">
                       <div class="embed-preview">
                         <iframe width="250" height="350" src="//www.nap.edu/widget/23659" frameborder="0" scrolling="no"></iframe>
                       </div>
                       <p class="embed-text">Copy the HTML code below to embed this book in your own blog, website, or application.</p>
                       <textarea class="embed-code form-control" noresize></textarea>
                       <div class="embed-size">
                         <div class="embed-label">Custom Size:</div>
                         <div class="embed-width">
                           <input type="number" id="embed-width-input" class="form-control embed-width-input" value="250" min="250" max="1000" step="50">
                         </div>
                         <div class="embed-x">&times;</div>
                         <div class="embed-height">
                           <input type="number" id="embed-height-input" class="form-control embed-height-input" value="350" min="350" max="500" step="50">
                         </div>
                       </div>
                       <div class="clearfix"></div>
                     </div>
                  </div>
                </div>
              </div>
          
             <!-- Modal - What is a prepub? -->
             <div class="modal fade" id="pp-modal" tabindex="-1" role="dialog" aria-labelledby="ppModalLabel" aria-hidden="true">
              <div class="modal-dialog">
                <div class="modal-content">
                  <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">What is a prepublication?</h4>
                  </div>
                  <div class="modal-body">
                    <img src="/images/icon_prepubprocess.png" alt="What is a prepublication image" border="0" class="img-responsive">
                    <p>An uncorrected copy, or prepublication, is an uncorrected proof of the book. We publish prepublications to facilitate timely access to the committee's findings.</p>
                                      </div>
                  <div class="modal-footer">
                    <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
                  </div>
                </div>
              </div>
            </div>
            <!-- / prepub modal -->
          
            <!-- Modal - What happens when I preorder? -->
            <div class="modal fade" id="po-modal" tabindex="-1" role="dialog" aria-labelledby="poModalLabel" aria-hidden="true">
              <div class="modal-dialog">
                <div class="modal-content">
                  <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">What happens when I pre-order?</h4>
                  </div>
                  <div class="modal-body">
                    <p>The final version of this book has not been published yet. You can pre-order a copy of the book and we will send it to you when it becomes available.  We will not charge you for the book until it ships. Pricing for a pre-ordered book is estimated and subject to change. All backorders will be released at the final established price. As a courtesy, if the price increases by more than $3.00 we will notify you.<br><br> If the price decreases, we will simply charge the lower price.<br><br>Applicable discounts will be extended.</p>
                  </div>
                  <div class="modal-footer">
                    <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
                  </div>
                </div>
              </div>
            </div>
            <!-- / preorder modal -->

           <!-- Modal - What is an Ebook? -->
            <div class="modal fade" id="ebook-modal" tabindex="-1" role="dialog" aria-labelledby="ppModalLabel" aria-hidden="true">
              <div class="modal-dialog">
                <div class="modal-content">
                  <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">Downloading and Using eBooks from NAP</h4>
                  </div>
                  <div class="modal-body">
                    <h4>What is an eBook?</h4>
                    <p>An ebook is one of two file formats that are intended to be used with e-reader devices and apps such as Amazon Kindle or Apple iBooks.</p>
                    <h4>Why is an eBook better than a PDF?</h4>
                    <p>A PDF is a digital representation of the print book, so while it can be loaded into most e-reader programs, it doesn't allow for resizable text or advanced, interactive functionality. The eBook is optimized for e-reader devices and apps, which means that it offers a much better digital reading experience than a PDF, including resizable text and interactive features (when available).</p>
                    <h4>Where do I get eBook files?</h4>
                    <p>eBook files are now available for a large number of reports on the NAP.edu website. If an eBook is available, you'll see the option to purchase it on the book page.</p>
                    <p><a href="/content/download-and-using-ebooks-from-nap" target="_blank">View more FAQ's about Ebooks</a></p>
                  </div>
                  <div class="modal-footer">
                    <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
                  </div>
                </div>
              </div>
            </div>
            <!-- / ebook modal -->
			
			<!-- Modal - What is a publication type? -->
             <div class="modal fade" id="type-modal" tabindex="-1" role="dialog" aria-labelledby="typeModalLabel" aria-hidden="true">
              <div class="modal-dialog">
                <div class="modal-content">
                  <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">Types of Publications</h4>
                  </div>
                  <div class="modal-body">
                    <p><strong>Proceedings: </strong>Proceedings chronicle the presentations and discussions at a workshop, symposium, or other convening event. The statements and opinions contained in proceedings are those of the participants and have not been endorsed by other participants, the planning committee, or the National Academies of Sciences, Engineering, and Medicine.</p>
                  </div>
                  <div class="modal-footer">
                    <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
                  </div>
                </div>
              </div>
            </div>
            <!-- / pub type modal -->
          
          </div>  
                      </div>
    </div>
    
    <div class="container">
      <div class="tabs-row row">
        <ul class="nav nav-tabs visible-md visible-lg">
          <li class="active"><a href="#overview" data-toggle="tab">Overview</a></li>
                      <li><a href="#toc" data-toggle="tab">Contents</a></li>
                                                    <li><a href="#research" data-toggle="tab">Research</a></li>
                                <li><a href="#rights" data-toggle="tab">Rights</a></li>
                              <div class="clearfix"></div>
        </ul>
      </div>
    </div>
    
    <div class="tab-content-rows">
      <div class="container">
        <div class="tab-content"><div class="mobile-tab visible-sm visible-xs" data-target="#overview"><span class="caret"></span> Overview</div>
                    <div id="overview" class="tab-pane fade in active">
    
                
                       
                          <h3><span class="icon-heading" data-icon="&#xe6a8;"></span> Contributors</h3>
              <div class="book-author" itemprop="author">
                                  National Academy of Engineering
                              </div>
                
                          <h3><span class="icon-heading" data-icon="&#xe6ad;"></span> Description</h3>
              <div class="book-description" itemprop="description"><p>This volume presents papers on the topics covered at the National Academy of Engineering's 2016 US Frontiers of Engineering Symposium. Every year the symposium brings together 100 outstanding young leaders in engineering to share their cutting-edge research and innovations in selected areas. The 2016 symposium was held September 19-21 at the Arnold and Mabel Beckman Center in Irvine, California. The intent of this book is to convey the excitement of this unique meeting and to highlight innovative developments in engineering research and technical work.</p>
</div>
                
                          <h3><span class="icon-heading" data-icon="&#xe66b;"></span> Topics</h3>
              <ul class="book-topics">
                                                    <li><a href="/topic/360">
                                          <span itemprop="about">Engineering and Technology</span>
                                                              &mdash; Applications of Technology
                                      </a></li>
                                                    <li><a href="/topic/365">
                                          Engineering and Technology
                                                              &mdash; Policy, Reviews and Evaluations
                                      </a></li>
                              </ul>
            
                          <h3>Publication Info</h3>
                              <span itemprop="numberOfPages">144</span> pages 
                             |                               6 x 9
                            <br>                              Paperback
                 <br>
                ISBN: <span itemprop="isbn">978-0-309-45036-2</span> <br>
                                            DOI: <a href="https://doi.org/10.17226/23659">https://doi.org/10.17226/23659</a> <br>
                              
          </div>
    
          
                      <div class="mobile-tab visible-sm visible-xs" data-target="#toc"><span class="caret"></span> Contents</div>
                              <div id="toc" class="tab-pane fade">
              <div class=" graysearchouter">
    <form class="search-form" role="form" action="//www.nap.edu/booksearch.php" method="GET" title="Search NAP Books">
      <input type="hidden" name="record_id" value="23659">
      <input type="hidden" name="booksearch" value="1">
      <div class="searchinput">
        <label class="sr-only" for="inputsearch">Search Inside This Book</label>
        <input type="text" name="term" id="inputsearch" placeholder="Search Inside This Book" required>
        <button type="submit" class="btn-blueflat btn-searchhome hide-xs">
          <span class="icon-menu icon-search" data-icon="&#xe6b6;"> </span>
          <span class="hidden-xxs">SEARCH</span>
        </button>
      </div>
      <div class="clearfix"></div>
    </form>
  </div>

            <table class="table">
              <thead>
                <tr>
                  <th><h3>Table of Contents</h3></th>
                  <th class="key-chapskim" colspan="2"><span class="glyphicon glyphicon-eye-open icon-skim"> </span> skim chapter</th>
                </tr>
              </thead>
              <tbody>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/1">Front Matter</a></td>
                    <td class="chapter-page-range">i-xii</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=i-xii" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/2">PIXELS AT SCALE: HIGH-PERFORMANCE COMPUTER GRAPHICS AND VISION</a></td>
                    <td class="chapter-page-range">1-2</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=1-2" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/3">Pixelsat Scale: High-Performance Computer Graphics and Vision - David Luebke and John Owens</a></td>
                    <td class="chapter-page-range">3-6</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=3-6" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/4">Computational Near-Eye Displays: Engineering the Interface to the Digital World - Gordon Wetzstein</a></td>
                    <td class="chapter-page-range">7-12</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=7-12" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/5">Frontiers in Virtual Reality Headsets - Warren Hunt</a></td>
                    <td class="chapter-page-range">13-16</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=13-16" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/6">First-Person Computational Vision - Kristen Grauman </a></td>
                    <td class="chapter-page-range">17-24</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=17-24" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/7">A Quintillion Live Pixels: The Challenge of Continuously Interpreting and Organizing the World&#039;s Visual Information - Kayvon Fatahalian</a></td>
                    <td class="chapter-page-range">25-28</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=25-28" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/8">EXTREME ENGINEERING: EXTREME AUTONOMY IN SPACE, AIR, LAND, AND UNDER WATER</a></td>
                    <td class="chapter-page-range">29-30</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=29-30" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/9">Extreme Engineering: Extreme Autonomy in Space and Air, on Land, and Under Water - DeShawn Jackson and Marco Pavone</a></td>
                    <td class="chapter-page-range">31-32</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=31-32" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/10">Autonomous Precision Landing of Space Rockets - Lars Blackmore</a></td>
                    <td class="chapter-page-range">33-42</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=33-42" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/11">Autonomy Under Water: Ocean Sampling by Autonomous Underwater Vehicles - Derek A. Paley</a></td>
                    <td class="chapter-page-range">43-50</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=43-50" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/12">WATER DESALINATION AND PURIFICATION</a></td>
                    <td class="chapter-page-range">51-52</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=51-52" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/13">Water Desalination and Purification - Amy Childress and Abhishek Roy</a></td>
                    <td class="chapter-page-range">53-54</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=53-54" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/14">Water Desalination: History, Advances, and Challenges - Manish Kumar, Tyler Culp, and Yuexiao Shen</a></td>
                    <td class="chapter-page-range">55-68</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=55-68" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/15">Scalable Manufacturing of Layer-by-Layer Membranes for Water Purification - Christopher M. Stafford</a></td>
                    <td class="chapter-page-range">69-74</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=69-74" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/16">New Materials for Emerging Desalination Technologies - Baoxia Mi</a></td>
                    <td class="chapter-page-range">75-82</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=75-82" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/17">High-Recovery Desalination and Water Treatment - Kevin L. Alexander</a></td>
                    <td class="chapter-page-range">83-90</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=83-90" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/18">TECHNOLOGIES FOR UNDERSTANDING AND TREATING CANCER</a></td>
                    <td class="chapter-page-range">91-92</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=91-92" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/19">Technologies for Understanding and Treating Cancer - Julie Champion and Peter Tessier</a></td>
                    <td class="chapter-page-range">93-94</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=93-94" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/20">How Cancer Cells Go Awry: The Role of Mechanobiology in Cancer Research - Cynthia A. Reinhart-King</a></td>
                    <td class="chapter-page-range">95-100</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=95-100" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/21">Engineered Proteins for Visualizing and Treating Cancer - Jennifer R. Cochran</a></td>
                    <td class="chapter-page-range">101-106</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=101-106" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/22">Engineering Immunotherapy - Darrell J. Irvine</a></td>
                    <td class="chapter-page-range">107-112</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=107-112" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/23">APPENDIXES</a></td>
                    <td class="chapter-page-range">113-114</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=113-114" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/24">Contributors</a></td>
                    <td class="chapter-page-range">115-120</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=115-120" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/25">Participants</a></td>
                    <td class="chapter-page-range">121-128</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=121-128" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                                                                      <tr>
                    <td class="chapter-name"><a href="https://www.nap.edu/read/23659/chapter/26">Program</a></td>
                    <td class="chapter-page-range">129-132</td>
                    <td class="chapter-skim">
                      <a href="//www.nap.edu/nap-cgi/skimchap.cgi?recid=23659&chap=129-132" class="btn btn-sm btn-skim"><span class="glyphicon glyphicon-eye-open icon-skim"></span></a>
                    </td>
                  </tr>
                              </tbody>
            </table>
          </div>
      
                              <div id="resources" class="tab-pane fade">
    
                
                
                
                
                
          </div>
    
                              <div id="multimedia" class="tab-pane fade">
    
                
                      </div>
    
                      <div class="mobile-tab visible-sm visible-xs" data-target="#research"><span class="caret"></span> Research</div>
                        <div id="research" class="tab-pane fade">
            
                              <h3><span class="icon-heading" data-icon="&#xe65a;"></span> Suggested Citation</h3>
                <div class="citation-string">National Academy of Engineering.  2017. <em>Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium</em>. Washington, DC: The National Academies Press. doi:https://doi.org/10.17226/23659.</div>
                <h3 class="muted">Import this citation to:</h3>
                <ul class="citation-formats">
                                      <li><a href="/citation.php?type=bibtex&amp;record_id=23659">Bibtex</a></li>
                                      <li><a href="/citation.php?type=enw&amp;record_id=23659">EndNote</a></li>
                                      <li><a href="/citation.php?type=ris&amp;record_id=23659">Reference Manager</a></li>
                                  </ul>
                            
        <h3> Reference Finder </h3>
              <p>Find relevant information like your own rough draft from among the thousands of reports available for free at NAP.edu. ​Copy and paste up to 8 pages of content&mdash;whether from your own draft or an outside article&mdash;and Reference Finder will recommend NAP publications related to your text.<br><br>
  <a href="//www.nap.edu/reffind.php" class="roundbtn_2">View Reference Finder</a> </p>
  
            </div>
          
                      <div class="mobile-tab visible-sm visible-xs" data-target="#rights"><span class="caret"></span> Rights</div>
            <div id="rights" class="tab-pane fade">
              <h3><span class="icon-heading" data-icon="&#xe729;"></span> Copyright Information</h3>
              <p>The National Academies Press (NAP) has partnered with Copyright Clearance Center's Rightslink service to offer you a variety of options for reusing NAP content. Through Rightslink, you may request permission to reprint NAP content in another publication, course pack, secure website, or other media. Rightslink allows you to instantly obtain permission, pay related fees, and print a license directly from the NAP website. The complete terms and conditions of your reuse license can be found in the license agreement that will be made available to you during the online order process. To request permission through Rightslink you are required to create an account by filling out a simple online form. The following list describes license reuses offered by the National Academies Press (NAP) through Rightslink:</p>
              <ul>
                <li>Republish text, tables, figures, or images in print</li>
                <li>Post on a secure Intranet/Extranet website</li>
                <li>Use in a PowerPoint Presentation</li>
                <li>Distribute via CD-ROM</li>
                <li>Photocopy</li>
              </ul>
                            <p><a href="https://s100.copyright.com/AppDispatchServlet?publisherName=NAP&amp;imprint=NAP&amp;publication=book&amp;title=Frontiers+of+Engineering%3A+Reports+on+Leading-Edge+Engineering+from+the+2016+Symposium&amp;contentID=23659&amp;publicationDate=2017&amp;author=National+Academy+of+Engineering&amp;sp=n&amp;pageCount=144&amp;orderBeanReset=true" target="_blank"><span class="icon-heading" data-icon="&#xe759;"></span> Click here to obtain permission for the above reuses.</a> If you have questions or comments concerning the Rightslink service, please contact:</p>
              <blockquote>Rightslink Customer Care<br>
              Tel (toll free): 877/622-5543<br>
              Tel: 978/777-9929<br>
              E-mail: customercare@copyright.com<br>
              Web: http://www.rightslink.com </blockquote>
              <p>To request permission to distribute a PDF, please contact our Customer Service Department at 800-624-6242 for pricing.</p>
              <p>To request permission to translate a book published by the National Academies Press or its imprint, the Joseph Henry Press, please <a href="//www.nap.edu/content/request/translation_rights.html">click here to view more information.</a></p> 
            </div>
          
              
        </div>
      </div>
    </div>
    
    <div id="related-books-rows" class="container ft">
      <p class="alert alert-info">Finding similar items... <img src="/images/loading.gif" class="pull-right"></p>
    </div>

  </div>

                
<a href="#" class="back-to-top"><span class="icon-menu" data-icon="&#xe760;"> </span></a>
 
<div id="fixedfooter" style="max-width: 100%; margin: 0 auto;">
  <footer id="global-footer" class="global-footer" > <a name="ftr_menu"></a> 
    
    <section class="full-width-top">
      <div class="footer13_top"><a href="#top">Back to top</a></div>
    </section>
    <div class="full-width-wrapper">
      <section class="footer-section">
        <h6>NAP Quick Links</h6>
        <ul>
          <li><a href="//www.nap.edu/">Home</a></li>
          <li><a href="//www.nap.edu/content/about-the-national-academies-press">About</a></li>
          <li><a href="//www.nap.edu/gifts">Gifts & Apparel</a></li>
          <li><a href="http://notes.nap.edu/">Notes from NAP</a></li>
          <li><a href="//www.nap.edu/collection">Searchable Collections</a></li>

        </ul>
        <h6>Browse</h6>
          <ul>
            <li><a href="//www.nap.edu/topic">Browse by Topic</a></li>
            <li><a href="//www.nap.edu/new">Browse New Releases</a></li>
            <li><a href="//www.nap.edu/author">Browse by Division</a></li>
            <li><a href="//www.nap.edu/academy-scope">Browse with AcademyScope</a></li>
          </ul>
      </section>
       
      <section class="footer-section">
        <h6>NAP Help</h6>
        <ul>
          <li><a href="//www.nap.edu/content/contact-customer-service">Contact Customer Service</a></li>         
        </ul>
        <h6>Using NAP.edu</h6>
        <ul>
          <li><a href="//www.nap.edu/content/searching-nap-publications">Tips for Searching</a> </li>
          <li><a href="//www.nap.edu/content/using-mynap">Help With MyNAP</a></li>
          <li><a href="//www.nap.edu/content/about-pdfs">Downloading and Reading PDFs</a> </li>
        </ul>
        <h6>Ordering</h6>
        <ul class="ordering">
          <li><a href="//www.nap.edu/content/help-with-ordering">Placing an Order</a></li>
          <li><a href="//www.nap.edu/content/returns">Returning a Book</a></li>
          <li><a href="//www.nap.edu/content/shipping-and-handling-options">Shipping and Handling Options</a> </li>
        </ul>
      </section>

      <section class="footer-section" >
        <h6>Information</h6>
        <ul>
          <li><a href="//www.nap.edu/content/help-with-discounts">Discounts</a></li>
          <li><a href="//www.nap.edu/content/information-for-book-trade-customers">Book Trade Customers</a></li>
          <li><a href="//www.nap.edu/content/request-rights-and-permissions">Rights and Permissions</a></li>
          <li><a href="//www.nap.edu/content/international-ordering-and-distribution">International Ordering and Distribution</a></li>
          <li><a href="//www.nap.edu/content/translation-rights">Translation Rights</a></li>
        </ul>
      </section>

      <section class="footer-section far-right">
        <h6>Connect with NAP</h6>
        <ul>
          <li class="footer13_email"><a href="/updates">E-mail Updates</a></li>
          <li class="footer13_fb"><a href="https://www.facebook.com/nationalacademies">Facebook</a></li>
          <li class="footer13_tw"><a href="https://twitter.com/theNASEM">Twitter</a></li>
          <li class="footer13_gp"><a href="https://plus.google.com/111471144526792699277/">Google Plus</a></li>
          <li class="footer13_rss"><a href="http://feeds.nap.edu/nap/new">RSS</a></li>
          <li class="footer13_pod"><a href="http://media.nap.edu/podcasts/">Podcasts</a></li>
          <li class="footer13_more"><a href="//www.nap.edu/content/about/connect.html">More</a></li>
        </ul>
      </section>
      <br clear="all" />

    </div>
   
    <section class="full-width">
      <br />
    <a href="http://www.nas.edu" title="The National Academies of Sciences, Engineering, and Medicine" target="_blank">
		<img src="/images/footer_naid.png" border="0" alt="The National Academies of Sciences, Engineering, and Medicine" style="max-width: 100%"></a> 
    
     <br clear="all">
      500 Fifth St. N.W. | 
      Washington, D.C. 20001<br>
      <br>
      Copyright &copy; 2017 National Academy of Sciences. All rights reserved.<br>
      <a href="http://www.national-academies.org/legal/">Terms of Use and Privacy Statement</a><br>
    </section>
  </footer>
</div>

<script src="//www.nap.edu/includes/js/jquery.dlmenu.js"></script>
<script src="//www.nap.edu/includes/js/jquery.placeholder.js"></script>

<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->
<script>
  if (typeof $.placeholder === 'function') {
    $('input[placeholder]').placeholder();    
  }

  $('#bbt_Btn').on('click', function() { 
    $('.bbt-wrapper').slideToggle("slow");
  });

  $('#mobile_menuBtn').on('click', function() {
    $('.mobilemenu').slideToggle('slow');
    $('.mobilesearch, .mobileuser').slideUp();
  });

  // Simplification of Barebones Lightbox Template
  // by Kyle Schaeffer - kyleschaeffer.com
  function lightbox(content) {
    if ($('#lightbox').size() === 0) {
      $('<div id="lightbox"/><div id="lightbox-shadow"/>')
        .appendTo('body');
    }
    $('#lightbox').empty().append(content);
    $('#lightbox, #lightbox-shadow').fadeIn();
  }
  function closeLightbox() {
    $('#lightbox, #lightbox-shadow').fadeOut(function() {
      $('lightbox').empty();
    });
    return false;
  }

  // Wrapper for all the places that call GB_showImage
  // in their onclick attribute
  function GB_showImage(title, image) {
    lightbox('<img src="' + image + '"/>');
    $('#lightbox, #lightbox-shadow').on('click', closeLightbox);
    return false;
  }

  // Save to MyNAP handler
  $('a.saveit').one('click', function(e) {
    e.preventDefault();
    $.getJSON('/napsave.php', {
        type: 'shelf', 
        r: $(this).data('recordid')
      }, function(response) {
        $(e.target)
          .toggleClass('saveit saveit_active')
          .attr('href', '/mynap.php')
          .text('Added to Bookshelf');
    });
  });

  // Back To Top control
  $(function() {
    var offset = 220;
    var duration = 500;
    $(window).scroll(function() {
      if ($(this).scrollTop() > offset) {
        $('.back-to-top').fadeIn(duration);
      } else {
        $('.back-to-top').fadeOut(duration);
      }
    });
    $('.back-to-top').on('click', function(event) {
      event.preventDefault();
      $('html, body').animate({scrollTop: 0}, duration);
      return false;
    });
  });
</script>    
      <script src="/vendor/bootstrap/3.1.1/bootstrap.min.js"></script>
  <script src="/includes/js/jquery.dotdotdot.min.js" type="text/javascript"></script>
  <script src="//code.highcharts.com/highcharts.js"></script>
  <script src="//code.highcharts.com/maps/modules/map.js"></script>
  <script src="//code.highcharts.com/mapdata/custom/world.js"></script>
  <script>

    // function trackEvent(category, action, label) {
    //   console.log(category, action, label);
    // }

    $('.merchpurch select').on('change', function() {
      $(this).siblings('button').prop('disabled', $(this).val() == '');
    });

    $('#related-books-rows').load('rows', function() {
      $('.truncate').dotdotdot({
        watch: true,
        lastCharacter: {
          remove: [' ', ',', ';', '.', '!', '?']
        }
      });
    });

    if ( $('.book-description').children().length > 1 ) {
      $('.book-description').children(':gt(0)').hide();
      $('.book-description').children(':first').after('<a href="#" class="readmore">[read full description]</a>');
      $('.book-description a.readmore').on('click', function(e) {
        e.preventDefault();
        $('.book-description').children(':gt(0)').fadeIn();
        $('.book-description a.readmore').remove();
        trackEvent('catalog', 'description', 'show');
      });
    }

    $('.status-popover, [data-content]').popover({
      trigger: 'hover',
      container: 'body'
    });

    $('.nav-tabs [href="#stats"]').one('shown.bs.tab', function(e) {
      $('#stats').load('/catalog/23659/stats');
    });

    $('.mobile-tab[data-target="#stats"]').one('click', function(e) {
      $('#stats').load('/catalog/23659/stats');
    });

    function openDefaultTab() {
      var hash = window.location.hash;
      var tabs = $('.nav-tabs>li>a').map(function() { return $(this).attr('href'); }).get();
      var index = tabs.indexOf(hash);
      if (index > 0) {
        $('.nav-tabs>li>a').eq(index).tab('show');
      }
    }
    openDefaultTab();

    $('.nav-tabs [data-toggle=tab]').one('shown.bs.tab', function() {
      var $target = $($(this).attr('href'));
      $target.find('iframe').attr('src', function(i, val) { return val; });
    });

    $('.nav-tabs [data-toggle=tab]').on('show.bs.tab', function(e) {
      trackEvent('catalog', 'tab', $(this).text());
      var target = $(this).attr('href');
      $('.mobile-tab[data-target="' + target + '"]').toggleClass('active');
    });

    $('.mobile-tab').on('click', function(e) {
      trackEvent('catalog', 'mobile-tab', $(this).text());
      e.preventDefault();
      var target = $(this).data('target');
      $(target).css({'opacity': 1}).toggle();
      $(this).toggleClass('active');
    });

    // Save to MyNAP handler
    $('a.action-add').one('click', function(e) {
      e.preventDefault();
      $.getJSON('/napsave.php', {
          type: 'shelf', 
          r: $(this).data('recordid')
        }, function(response) {
          $(e.target)
            .toggleClass('action-add action-add-active')
            .attr('href', '/mynap')
            .text('Added to Bookshelf');
          trackEvent('catalog', 'shelf', $(e.target).data('recordid'));
      });
    });

    $("[id$='modal']").on('show.bs.modal', function() {
      trackEvent('catalog', 'modal', $(this).attr('id'));
    }).on('hide.bs.modal', function() {
      trackEvent('catalog', 'modal', $(this).attr('id'));
    });

    $('.citation-formats a').on('click', function() {
      trackEvent('catalog', 'citation', $(this).text());
    });

    $('.email-this').on('click', function() {
      trackEvent('catalog', 'email', '23659');
    });

    $('.cover-block').on('click', function() {
      trackEvent('catalog', 'cover', 'show');
    });

    $('#related-books-rows').on('click', '.book-row a', function() {
      trackEvent('catalog', 'rows', $(this).closest('.book-row').data('title'));
    });

    $('#purchase .panel-heading a').on('click', function() {
      trackEvent('catalog', 'mynap', $(this).text());
    });

    /**
     * Allow the user to customize the width and height of the widget,
     * but constrain the values to sizes that don't look bad.
     */
    Math.clamp = function(value, min, max) {
      return Math.max(min, Math.min(max, value));
    };
    updateEmbedCode = function(width, height) {
      width = width || 250;
      height = height || 350;
      var html = '<iframe width="' + width + '" height="' + height + '" '
        + 'src="//www.nap.edu/widget/23659" '
        + 'frameborder="0" scrolling="no"></iframe>';
      $('#embed-modal textarea.embed-code').val(html);
      $('#embed-modal .embed-preview iframe').width(width).height(height);
      $('#embed-modal .modal-dialog').width(width + 40);
      return true;
    };
    updateEmbedCode();
    $('#embed-modal input').on('change keyup', function() {
      var w = Math.clamp($('#embed-modal input.embed-width-input').val(), 250, 1000),
          h = Math.clamp($('#embed-modal input.embed-height-input').val(), 350, 500);
      updateEmbedCode(w, h);
    });

    $('#embed-modal textarea.embed-code').on('click focus', function() {
      $(this).select();
      trackEvent('embed', 'focus');
    });
  </script>

    
    <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=napdigops"></script> 
  <script type="text/javascript">
    addthis.layers({
      'theme' : 'transparent',
      'share' : {
        'position' : 'left',
        'numPreferredServices' : 4,
        'services': 'facebook,twitter,linkedin,email,more'
      },
      'responsive' : {
        'maxWidth': '1210px'
      } 
    });
  </script> 

  <script>
  var addthis_share = {
    url: 'nap.edu/23659',
    title: 'Frontiers of Engineering: Reports on Leading-Edge Engineering from the 2016 Symposium',
    
      templates: {
        twitter: '{{title}} | {{url}} via @theNASEM'
      }
    
  };
  </script>

          <!-- 144.171.20.54 -->
    
  </body>
</html>